Does the Express PowerPoint plugin work for Mac?

Currently the Express Plugin requires Windows XP, Vista, 7, 8 & 10 and PowerPoint 2007 and up (including Office 365)

Feedback

This is great! Will keep myself updated for future launching.

https://worcesterconcrete.com

Richard Mon (11/22/2021 at 3:57 AM)
Thank you for this info.
http://hudsonvalleydeckandfence.com

Mary Solero (12/15/2021 at 6:16 AM)